Claas Lexion handle pinmapping

Evening all,
Been fitting up autosteer to my combine, and have wired the enable line into the handle’s currently redundant autosteer button.
I’ve attached an excel file of the pin mapping for the DB25 connector. There is a common +5v rail, most buttons are push-to-make, except header ‘soft stop’ which is push-to-break, I guess for safety.
LED+ is 5v, LED- and GND are common.
There are 3 special buttons which I believe exist on later versions of the handle (units with touchscreen Cebis), function unkown. See below photo with contacts marked SA, SB and SC.

Hopefully someone finds this useful, theoretically one could add machine automation too by injecting signals to the buttons… :slight_smile:

cmotion handle pinmap.xlsx (9.1 KB)

2 Likes

I have connected a few retrofit gps systems to the lexion autopilot button via the DB25 connector. The common 5v you say is not 5v, it is 12v pwm at 50% duty. Switches are as you say NO or NC. The reason for the 50% pwm is so the ecu can detect problems with the switch, if the pwm doesn’t match when the button is pressed then there is a fault.
I just take a signal from the autopilot button into a frequency switch relay then connect relay contacts to whatever autosteer you have.

You are right it would be easy to simulate these switches to automate the machine, hadn’t thought of doing that. Might have to try that next harvest.

I think the signals on the newer cebis touchscreen machines are different but haven’t done one yet.

2 Likes

Damn, I should’ve broken the scope out!
Thanks for the info

When you mention pwm matching, are the incoming and outgoing signals anded, to detect phase, or would it accept any old PWM?

I’m not 100% sure how it compares the signal. I did read the tech manual and from what I remember I got the impression it the wave pattern must match up. I guess that means the high and lows of the pwm from the switch must match with the common supply to all switches. To simulate one of the buttons you could use a relay to connect the common pwm to the switch output.

Did you update the xls with the new 12V/PWM info? I’m digging into the details for our 575R

No, but the only difference is that common is 12v PWM.

I made up a small circuit to take the square wave and convert it via an 817 optocoupler to an arduino friendly signal. You’ll need an interrupt capable pin set to input_pullup to use it. You can probably downsize the capacitor a huge amount, mine was 47uF because that’s what I had lying around, but it does produce a nice big fat signal for the arduino.

1 Like

I’m a little confused now. In your first post you say LED- and gnd are common. Can you be more specific? Do you mean that pin 25 (common) is the 12V PWM? How about in the spreadsheet regarding the note for LED+ 5V, is that also now 12V PWM?

Sorry, I should’ve been more clear with my wording all round. LED- (pin 21) can be regarded as chassis ground, as I can get continuity with a multimeter. However I have named it LED- as only the LEDs use this pin, and while LED- and chassis are referenced to each other, I cannot be 100% sure what’s going on between them.

Pin 25 is the common +12v PWM, which is then fed to the relevant pins when you push a button.

Pin 10, LED+ is now unknown. It could be either +5V or 12V PWM and I didn’t test it because I have no plans to use the LEDs

1 Like

I’ve been looking around on our 575R and I can see how to simulate a button press with a relay (connect 12v PWM to button wire) but I can’t figure out how to monitor a button with the Arduino, I can’t find a ground common to the 12v PWM signal.

Use the circuit I posted a couple of posts ago, and connect between the button of interest and chassis ground, The 12V PWM is referenced to chassis so you don’t need to connect ground to anything back in the handle, as long as your circuit ground is connected to the main ground of the combine.

That’s the thing, it doesn’t seem to be referenced to chassis ground on mine.

What tests have you done? Can you get continuity between pin21 and chassis?
If you put a multimeter or scope between your button pin and chassis what happens?

I used a multimeter to confirm continuity between the common PWM pin 25 and the autosteer pin 17 when I press the button. I also used a multimeter to check voltage to chassis ground on pin 17 while pressing the button, I get a 0 reading regardless of whether I’m pressing the button.

Were you checking AC volts or DC volts? tried a different meter? Maybe your multimeter isn’t playing nice with the PWM. Maybe try using an LED with 470 ohm resistor and connect that between pin 17 and chassis.
Or maybe try and find voltage between pin17 and pin21?

I only tapped into pin 17 (autosteer btn) so I’ll try with the o-scope on that line. I’m going to look for an inline 25pin breakout/proto board something to take a closer look again later.

1 Like

On my 2005 575R the button pin outs match yours but instead of the buttons connecting to a common PWM signal on pin 25, it just uses a common ground, which is also common to chassis ground when the engine is running.

Edit. Should add that some button’s lines are pulled up to 13.8V, some to 10.3V and some to 5V. I looked at them all with the scope and it looked like a solid voltage.